in reply to Getter and Setter Function Names
Having just done courses on Java and Enterprise Java recently (I just became an evil management/IT consultant) I rather like the traditional getSalary() and setSalary() and toString() accessor, mutator and accessor/casting (they teach us cool and inscrutable words too) method standard. They act as good visual cues as to what is going on in the program, whereas the overloading route is less obvious and may make maintaining the code harder.
In general though, I like the idea of standardised method names as it makes life so much easier: I'm doing a smidgeon of J++ coding at the moment and I was taught in (real) Java, which uses the standard ways of doing things, whereas the bastardised version we are currently using has subtly different implementations of the same libraries. This also includes some of the method names as far as I can tell (I could be wrong, the learning curve is still steep.)
I guess I'd say this as a final quip- it doesn't actually really matter, provided that they are carefully documented.
"What this book tells me is that goose-stepping morons, such as yourself, should read books instead of burning them."
- Dr. Jones Snr, Indiana Jones and the Last Crusade