http://qs321.pair.com?node_id=391402

HelgeG has asked for the wisdom of the Perl Monks concerning the following question:

I am still finding my way around in the world of perl, so this question might be basic. I am looking for a Curses implementation that will run on Activestate Perl 5.8.4 (WinXP). On CPAN the only ppm modules available are for v5.6. Can I use these, or will I need a package that is specific to 5.8?

Replies are listed 'Best First'.
Re: Curses, Win32 and Perl 5.8
by tachyon (Chancellor) on Sep 16, 2004 at 11:15 UTC

    You need one specific to 5.8 as it is not binary compatible with 5.6. crazyinsomniac maintains a ppm repository that often has useful modules but he only has Curses for 5.6. If you /msg him he may do a 5.8 version or tell you how easy it (is not) to compile.

    You could of course just install 5.6 which is fine unless you want some rather specific widgets that appeared in 5.8.

    cheers

    tachyon

      Thanks for the suggestion. I'll try to nudge crazyinsomniac into doing a 5.8 version.

      I have a tendency towards latestversionitis, but installing 5.6 is also a viable option.