http://qs321.pair.com?node_id=864176

targetsmart has asked for the wisdom of the Perl Monks concerning the following question:

Hi Monks, I was using activeperl 5.6.1 for a long time, when I decided to try new strawberry perl 5.8.9, I faced a strange issue.

I installed strawberry perl in its default location C:\strawberry, and put the C:\strawberry\perl\bin as the first item in the path variable, and launched a new command prompt and typed perl --version; it correctly said perl 5.8.9, but the strange thing happened when I just put "use 5.8.9;" inside the perl scripts which I had. I got the below error ..

Perl v5.8.9 required--this is only v5.6.1, stopped at xyz.pl line 2. BEGIN failed--compilation aborted at xyz.pl line 2.
I don't want to disturb existing 5.6.1 but still try 5.8.9.
any help is greatly appreciated..


Vivek
-- 'I' am not the body, 'I' am the 'soul/consciousness', which has no beginning or no end, no attachment or no aversion, nothing to attain or lose.