Beefy Boxes and Bandwidth Generously Provided by pair Networks
The stupid question is the question not asked
 
PerlMonks  

Re^7: (Help Needed) Uninstall Perl 5.10 and Install 5.8 on Ubuntu 10.04

by marto (Cardinal)
on Sep 14, 2010 at 11:38 UTC ( #860095=note: print w/replies, xml ) Need Help??


in reply to Re^6: (Help Needed) Uninstall Perl 5.10 and Install 5.8 on Ubuntu 10.04
in thread (Help Needed) Uninstall Perl 5.10 and Install 5.8 on Ubuntu 10.04

Your thread has moved on from you asking for help building your own perl to installing another application. You should have read the prerequisites of the application, it needs perl to be compiled with threads. If you've copied what I gave you, this won't happen as stated in the perl INSTALL file:

"On some platforms, perl can be compiled with support for threads. To enable this, run

sh Configure -Dusethreads

The default is to compile without thread support."

You can't add this later on, it has to be done at compile time. So to go back to my inital advice and update it for an installation using threads:

./Configure -des -Dusethreads -Dprefix=$HOME/Your/other/path/here make test make install

The lesson here is to read the documentation of the product you are trying to install, and the tools you need to compile to use to product. Also, you could do some seaching to find out why problems happen ;)

Update: fixed closing code tag, reworded opening line.

Log In?
Username:
Password:

What's my password?
Create A New User
Domain Nodelet?
Node Status?
node history
Node Type: note [id://860095]
help
Chatterbox?
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others having an uproarious good time at the Monastery: (4)
As of 2022-01-19 21:18 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?
    In 2022, my preferred method to securely store passwords is:












    Results (56 votes). Check out past polls.

    Notices?