Beefy Boxes and Bandwidth Generously Provided by pair Networks
Problems? Is your data what you think it is?
 
PerlMonks  

Re^4: (Help Needed) Uninstall Perl 5.10 and Install 5.8 on Ubuntu 10.04

by skumar1 (Initiate)
on Sep 13, 2010 at 11:21 UTC ( #859974=note: print w/replies, xml ) Need Help??


in reply to Re^3: (Help Needed) Uninstall Perl 5.10 and Install 5.8 on Ubuntu 10.04
in thread (Help Needed) Uninstall Perl 5.10 and Install 5.8 on Ubuntu 10.04

Thanks. Now I am getting perl version as "5.12.2".
root@cvsnew:/usr/bin# /opt/perl-5.12.2/bin/perl -v This is perl 5, version 12, subversion 2 (v5.12.2) built for i686-linu +x
<note> I run checksetup command and found some modules are missing. Please see below:
root@cvsnew:/var/www/bugzilla-3.4# ./checksetup.pl * This is Bugzilla 3.4.3 on perl 5.12.2 * Running on Linux 2.6.32-24-generic-pae #41-Ubuntu SMP Thu Aug 19 02: +43:57 UTC 2010 Checking perl modules... Checking for CGI.pm (v3.33) ok: found v3.48 Checking for Digest-SHA (any) ok: found v5.47 Checking for TimeDate (v2.21) ok: found v2.24 Class::ISA will be removed from the Perl core distribution in the next + major release. Please install it from CPAN. It is being used at lib/ +DateTime/Locale/Base.pm, line 6. Checking for DateTime (v0.28) ok: found v0.51 Checking for DateTime-TimeZone (v0.71) ok: found v1.03 Checking for DBI (v1.41) ok: found v1.613 Checking for Template-Toolkit (v2.22) ok: found v2.22 Checking for Email-Send (v2.00) ok: found v2.198 Checking for Email-MIME (v1.861) ok: found v1.901 Checking for Email-MIME-Encodings (v1.313) ok: found v1.313 Checking for Email-MIME-Modifier (v1.442) ok: found v1.901 Checking for URI (any) ok: found v1.55 Checking available perl DBD modules... Checking for DBD-Pg (v1.45) ok: found v2.17.1 Checking for DBD-mysql (v4.00) ok: found v4.017 Checking for DBD-Oracle (v1.19) not found The following Perl modules are optional: Checking for GD (v1.20) ok: found v2.45 Checking for Chart (v1.0) ok: found v2.4.1 Checking for Template-GD (any) ok: found v1.56 Checking for GDTextUtil (any) ok: found v0.86 Checking for GDGraph (any) ok: found v1.44 Checking for XML-Twig (any) ok: found v3.35 Checking for MIME-tools (v5.406) ok: found v5.428 Checking for libwww-perl (any) ok: found v5.835 Checking for PatchReader (v0.9.4) ok: found v0.9.5 Checking for PerlMagick (any) not found Checking for perl-ldap (any) ok: found v0.39 Checking for Authen-SASL (any) ok: found v2.13 Checking for RadiusPerl (any) ok: found v0.15 defined(%hash) is deprecated at lib/SOAP/Lite.pm line 466, <DATA> line + 275. (Maybe you should just omit the defined()?) defined(%hash) is deprecated at lib/SOAP/Lite.pm line 2204, <DATA> lin +e 275. (Maybe you should just omit the defined()?) Checking for SOAP-Lite (v0.710.06) ok: found v0.710.10 Checking for HTML-Parser (v3.40) ok: found v3.68 Checking for HTML-Scrubber (any) ok: found v0.08 Checking for Email-MIME-Attachment-Stripper (any) ok: found v1.316 Checking for Email-Reply (any) ok: found v1.202 Checking for TheSchwartz (any) ok: found v1.10 Checking for Daemon-Generic (any) ok: found v0.61 Checking for mod_perl (v1.999022) not found ********************************************************************** +* * OPTIONAL MODULES +* ********************************************************************** +* * Certain Perl modules are not required by Bugzilla, but by +* * installing the latest version you gain access to additional +* * features. +* * +* * The optional modules you do not have installed are listed below, +* * with the name of the feature they enable. Below that table are the +* * commands to install each module. +* ********************************************************************** +* * MODULE NAME * ENABLES FEATURE(S) +* ********************************************************************** +* * PerlMagick * Optionally Convert BMP Attachments to PNGs +* * mod_perl * mod_perl +* ********************************************************************** +* COMMANDS TO INSTALL OPTIONAL MODULES: PerlMagick: /opt/perl-5.12.2/bin/perl install-module.pl Image::Ma +gick mod_perl: /opt/perl-5.12.2/bin/perl install-module.pl mod_perl2 To attempt an automatic install of every required and optional module with one command, do: /opt/perl-5.12.2/bin/perl install-module.pl --all Attempt to reload DateTime.pm aborted. Compilation failed in require at Bugzilla/Util.pm line 53, <DATA> line + 275. BEGIN failed--compilation aborted at Bugzilla/Util.pm line 53, <DATA> +line 275. Compilation failed in require at Bugzilla/Hook.pm line 26, <DATA> line + 275. BEGIN failed--compilation aborted at Bugzilla/Hook.pm line 26, <DATA> +line 275. Compilation failed in require at Bugzilla/Config.pm line 37, <DATA> li +ne 275. BEGIN failed--compilation aborted at Bugzilla/Config.pm line 37, <DATA +> line 275. Compilation failed in require at Bugzilla.pm line 38, <DATA> line 275. BEGIN failed--compilation aborted at Bugzilla.pm line 38, <DATA> line +275. Compilation failed in require at ./checksetup.pl line 98, <DATA> line +275.
<Note> I tried to install mod_perl, but it failed: </Note>
root@cvsnew:/var/www/bugzilla-3.4# /opt/perl-5.12.2/bin/perl install-m +odule.pl mod_perl2 Please provide a full path to 'apxs' executable (press Enter if you don't have it installed): /usr/bin/apxs2 Configuring Apache/2.2.14 mod_perl/2.0.4 Perl/v5.12.2 [ error] Using Perl 5.012002 w/o ithreads and 'worker' mpm httpd. [ error] Failed requirements: [ error] - Perl built with ithreads (build perl with -Dusethreads) Warning: No success on command[/opt/perl-5.12.2/bin/perl Makefile.PL +LIB="/var/www/bugzilla-3.4/lib" INSTALLMAN1DIR="/var/www/bugzilla-3.4 +/lib/man/man1" INSTALLMAN3DIR="/var/www/bugzilla-3.4/lib/man/man3" IN +STALLBIN="/var/www/bugzilla-3.4/lib/bin" INSTALLSCRIPT="/var/www/bugz +illa-3.4/lib/bin" INSTALLDIRS=perl] 'YAML' not installed, will not store persistent state GOZER/mod_perl-2.0.4.tar.gz /opt/perl-5.12.2/bin/perl Makefile.PL LIB="/var/www/bugzilla-3.4/li +b" INSTALLMAN1DIR="/var/www/bugzilla-3.4/lib/man/man1" INSTALLMAN3DIR +="/var/www/bugzilla-3.4/lib/man/man3" INSTALLBIN="/var/www/bugzilla-3 +.4/lib/bin" INSTALLSCRIPT="/var/www/bugzilla-3.4/lib/bin" INSTALLDIRS +=perl -- NOT OK Skipping test because of notest pragma Running make install Make had some problems, won't install
Kindly help me.

Replies are listed 'Best First'.
Re^5: (Help Needed) Uninstall Perl 5.10 and Install 5.8 on Ubuntu 10.04
by marto (Cardinal) on Sep 13, 2010 at 11:33 UTC

    You've not run the perl executable for your version, you're still running the version of perl installed with Ubuntu (showing up via the which perl command). Rather than run the command you've changed into the bin directory of your 5.12.2 install and run the 5.10.1 perl executable. Try running the following (exactly):

    /opt/perl-5.12.2/bin/perl -V

    Update: removed leading . character in the example.

      I am able to remove error message while running checksetup.pl. Only thing is that I am unable to install mod_pl.
      root@cvsnew:/var/www/bugzilla-3.4# ./checksetup.pl * This is Bugzilla 3.4.3 on perl 5.12.2 * Running on Linux 2.6.32-24-generic-pae #41-Ubuntu SMP Thu Aug 19 02: +43:57 UTC 2010 Checking perl modules... Checking for CGI.pm (v3.33) ok: found v3.48 Checking for Digest-SHA (any) ok: found v5.47 Checking for TimeDate (v2.21) ok: found v2.24 Checking for DateTime (v0.28) ok: found v0.51 Checking for DateTime-TimeZone (v0.71) ok: found v1.03 Checking for DBI (v1.41) ok: found v1.613 Checking for Template-Toolkit (v2.22) ok: found v2.22 Checking for Email-Send (v2.00) ok: found v2.198 Checking for Email-MIME (v1.861) ok: found v1.901 Checking for Email-MIME-Encodings (v1.313) ok: found v1.313 Checking for Email-MIME-Modifier (v1.442) ok: found v1.901 Checking for URI (any) ok: found v1.55 Checking available perl DBD modules... Checking for DBD-Pg (v1.45) ok: found v2.17.1 Checking for DBD-mysql (v4.00) ok: found v4.017 Checking for DBD-Oracle (v1.19) not found The following Perl modules are optional: Checking for GD (v1.20) ok: found v2.45 Checking for Chart (v1.0) ok: found v2.4.1 Checking for Template-GD (any) ok: found v1.56 Checking for GDTextUtil (any) ok: found v0.86 Checking for GDGraph (any) ok: found v1.44 Checking for XML-Twig (any) ok: found v3.35 Checking for MIME-tools (v5.406) ok: found v5.428 Checking for libwww-perl (any) ok: found v5.835 Checking for PatchReader (v0.9.4) ok: found v0.9.5 Checking for PerlMagick (any) not found Checking for perl-ldap (any) ok: found v0.39 Checking for Authen-SASL (any) ok: found v2.13 Checking for RadiusPerl (any) ok: found v0.15 defined(%hash) is deprecated at lib/SOAP/Lite.pm line 466, <DATA> line + 275. (Maybe you should just omit the defined()?) defined(%hash) is deprecated at lib/SOAP/Lite.pm line 2204, <DATA> lin +e 275. (Maybe you should just omit the defined()?) Checking for SOAP-Lite (v0.710.06) ok: found v0.710.10 Checking for HTML-Parser (v3.40) ok: found v3.68 Checking for HTML-Scrubber (any) ok: found v0.08 Checking for Email-MIME-Attachment-Stripper (any) ok: found v1.316 Checking for Email-Reply (any) ok: found v1.202 Checking for TheSchwartz (any) ok: found v1.10 Checking for Daemon-Generic (any) ok: found v0.61 Checking for mod_perl (v1.999022) not found ********************************************************************** +* * OPTIONAL MODULES +* ********************************************************************** +* * Certain Perl modules are not required by Bugzilla, but by +* * installing the latest version you gain access to additional +* * features. +* * +* * The optional modules you do not have installed are listed below, +* * with the name of the feature they enable. Below that table are the +* * commands to install each module. +* ********************************************************************** +* * MODULE NAME * ENABLES FEATURE(S) +* ********************************************************************** +* * PerlMagick * Optionally Convert BMP Attachments to PNGs +* * mod_perl * mod_perl +* ********************************************************************** +* COMMANDS TO INSTALL OPTIONAL MODULES: PerlMagick: /opt/perl-5.12.2/bin/perl install-module.pl Image::Ma +gick mod_perl: /opt/perl-5.12.2/bin/perl install-module.pl mod_perl2 To attempt an automatic install of every required and optional module with one command, do: /opt/perl-5.12.2/bin/perl install-module.pl --all defined(%hash) is deprecated at Bugzilla/Install/Localconfig.pm line 2 +65, <DATA> line 275. (Maybe you should just omit the defined()?) Reading ./localconfig... OPTIONAL NOTE: If you want to be able to use the 'difference between t +wo patches' feature of Bugzilla (which requires the PatchReader Perl modu +le as well), you should install patchutils from: http://cyberelk.net/tim/patchutils/ Checking for DBD-mysql (v4.00) ok: found v4.017 Checking for MySQL (v4.1.2) ok: found v5.1.41-3ubuntu12.6-l +og Removing existing compiled templates... Precompiling templates...done. Fixing file permissions... root@cvsnew:/var/www/bugzilla-3.4#
      I am getting error message while trying to install mod_perl module :
      root@cvsnew:/var/www/bugzilla-3.4# /opt/perl-5.12.2/bin/perl install-m +odule.pl mod_perl2 Please provide a full path to 'apxs' executable (press Enter if you don't have it installed): /usr/bin/apxs2 Configuring Apache/2.2.14 mod_perl/2.0.4 Perl/v5.12.2 [ error] Using Perl 5.012002 w/o ithreads and 'worker' mpm httpd. [ error] Failed requirements: [ error] - Perl built with ithreads (build perl with -Dusethreads) Warning: No success on command[/opt/perl-5.12.2/bin/perl Makefile.PL +LIB="/var/www/bugzilla-3.4/lib" INSTALLMAN1DIR="/var/www/bugzilla-3.4 +/lib/man/man1" INSTALLMAN3DIR="/var/www/bugzilla-3.4/lib/man/man3" IN +STALLBIN="/var/www/bugzilla-3.4/lib/bin" INSTALLSCRIPT="/var/www/bugz +illa-3.4/lib/bin" INSTALLDIRS=perl] 'YAML' not installed, will not store persistent state GOZER/mod_perl-2.0.4.tar.gz /opt/perl-5.12.2/bin/perl Makefile.PL LIB="/var/www/bugzilla-3.4/li +b" INSTALLMAN1DIR="/var/www/bugzilla-3.4/lib/man/man1" INSTALLMAN3DIR +="/var/www/bugzilla-3.4/lib/man/man3" INSTALLBIN="/var/www/bugzilla-3 +.4/lib/bin" INSTALLSCRIPT="/var/www/bugzilla-3.4/lib/bin" INSTALLDIRS +=perl -- NOT OK Skipping test because of notest pragma Running make install Make had some problems, won't install
      Please help me out. Sorry for pasting long code.

        Your thread has moved on from you asking for help building your own perl to installing another application. You should have read the prerequisites of the application, it needs perl to be compiled with threads. If you've copied what I gave you, this won't happen as stated in the perl INSTALL file:

        "On some platforms, perl can be compiled with support for threads. To enable this, run

        sh Configure -Dusethreads

        The default is to compile without thread support."

        You can't add this later on, it has to be done at compile time. So to go back to my inital advice and update it for an installation using threads:

        ./Configure -des -Dusethreads -Dprefix=$HOME/Your/other/path/here make test make install

        The lesson here is to read the documentation of the product you are trying to install, and the tools you need to compile to use to product. Also, you could do some seaching to find out why problems happen ;)

        Update: fixed closing code tag, reworded opening line.

Log In?
Username:
Password:

What's my password?
Create A New User
Domain Nodelet?
Node Status?
node history
Node Type: note [id://859974]
help
Chatterbox?
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others making s'mores by the fire in the courtyard of the Monastery: (5)
As of 2022-01-22 22:00 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?
    In 2022, my preferred method to securely store passwords is:












    Results (63 votes). Check out past polls.

    Notices?