Beefy Boxes and Bandwidth Generously Provided by pair Networks
Keep It Simple, Stupid
 
PerlMonks  

Re^3: CGI Not Returning Parameter that's there

by linuxer (Curate)
on Mar 21, 2009 at 22:57 UTC ( #752305=note: print w/replies, xml ) Need Help??


in reply to Re^2: CGI Not Returning Parameter that's there
in thread CGI Not Returning Parameter that's there

Sorry, the shown log entry doesn't say anything about the parameter list for the request which produced that log entry.

It shows your warning message (which indicates that parameter h wasn't set) with an empty string, a whitespace (or a possible undef in $h) at the position where $h should be interpolated... it's hard to guess, what caused that empty space between h: and t:.

The log doesn't say anything about the actual parameter list for the logged request.

What we see is the referrer's URL. That's the URL you were coming from (probably the URL you called before this logged one). And that URL contained parameter h in its query string (parameter list).

If I'm so badly wrong on this, please enlighten me and explain that log format to me.

Log In?
Username:
Password:

What's my password?
Create A New User
Domain Nodelet?
Node Status?
node history
Node Type: note [id://752305]
help
Chatterbox?
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others pondering the Monastery: (4)
As of 2023-01-28 07:47 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?

    No recent polls found

    Notices?