Beefy Boxes and Bandwidth Generously Provided by pair Networks
Problems? Is your data what you think it is?
 
PerlMonks  

Re^4: [OT] Problem installing Mozilla::Mechanize

by Gangabass (Vicar)
on Nov 13, 2007 at 10:36 UTC ( #650473=note: print w/replies, xml ) Need Help??


in reply to Re^3: [OT] Problem installing Mozilla::Mechanize
in thread [OT] Problem installing Mozilla::Mechanize

My last (i hope) error with Debian:

127:~/.cpan/build/Gtk2-MozEmbed-0.06# perl Makefile.PL Mozilla::DOM >= 0.01 not found. Package mozilla-gtkmozembed was not found in the pkg-config search pat +h. Perhaps you should add the directory containing `mozilla-gtkmozembed.p +c' to the PKG_CONFIG_PATH environment variable No package 'mozilla-gtkmozembed' found Package firefox-gtkmozembed was not found in the pkg-config search pat +h. Perhaps you should add the directory containing `firefox-gtkmozembed.p +c' to the PKG_CONFIG_PATH environment variable No package 'firefox-gtkmozembed' found Package mozilla-firefox-gtkmozembed was not found in the pkg-config se +arch path. Perhaps you should add the directory containing `mozilla-firefox-gtkmo +zembed.pc' to the PKG_CONFIG_PATH environment variable No package 'mozilla-firefox-gtkmozembed' found Package xulrunner-gtkmozembed was not found in the pkg-config search p +ath. Perhaps you should add the directory containing `xulrunner-gtkmozembed +.pc' to the PKG_CONFIG_PATH environment variable No package 'xulrunner-gtkmozembed' found *** can not find package for any of (mozilla-gtkmozembed >= 1.7, firef +ox-gtkmozembed >= 1.0, mozilla-firefox-gtkmozembed >= 1.0, xulrunner- +gtkmozembed >= 1.8) *** check that one of them is properly installed and available in PKG_ +CONFIG_PATH at Makefile.PL line 51

I spent one hour trying to find how in Debian one of the following packaged named mozilla-gtkmozembed|firefox-gtkmozembed|mozilla-firefox-gtkmozembed|xulrunner-gtkmozembed. But ... i can't :-(

What package do i need to install firefox-gtkmozembed?

I try:

# apt-get install firefox-devel # apt-get install firefox-dev # apt-get install firefox-gtkmozembed # apt-get install firefox-gtkmozembed-dev # apt-get install firefox-gtkmozembed-devel

But nothing helps me...

Replies are listed 'Best First'.
Re^5: [OT] Problem installing Mozilla::Mechanize
by theorbtwo (Prior) on Nov 13, 2007 at 12:09 UTC

    To amplify somebody else's advice: Perhaps you should add the directory containing `xulrunner-gtkmozembed.pc' means that xulrunner-gtkmozembed.pc isn't there. To find it, go to http://packages.debian.org, find the form at the bottom, fill in xulrunner-gtkmozembed.pc in keyword, pick the correct distribution, and hit search. Bingo, you know what package xulrunner-gtkmozembed.pc is in. Repeat the next time you seem to be missing a purticular file.

    To give new advice: Use <c> tags, not <pre> tags, on PM; they'll wrap long lines according to the user's preference, thus keeping the page from becomming horribly wide and difficult to read.

      Now i need mozilla-xpcom and i found (on packages.debian.org) that it in mozilla-dev package. And i install it but it does't help :-( Can you suggest something? This package is need by Mozilla::DOM.

        How about you contact DEBIAN for support?
        A reply falls below the community's threshold of quality. You may see it by logging in.
Re^5: [OT] Problem installing Mozilla::Mechanize
by moritz (Cardinal) on Nov 13, 2007 at 11:09 UTC
    I spent one hour trying to find how in Debian one of the following packaged named

    You're using the wrong tools:

    $ apt-cache search gtkmozembed libgecko2.0-cil - CLI binding for the GtkMozEmbed library, unstable ve +rsion libgtk-mozembed-ruby - ruby binding of GtkMozEmbed, gecko renderer libxul-common - Gecko engine library - common files libxul-dev - Development files for the Gecko engine library libxul0d - Gecko engine library libxul0d-dbg - Development files for the Gecko engine library

    My guess is that it's the libxul-dev package, but you have to try that out by yourself.

    Btw a usefull links is packges.debian.org, you can search for package contents there.

      Thanks for apt-cache search! Why did you does not tell it to me before? :-) This really helps me to solve gtkmozembed problem but i have new one (i hope the last) -- i can't install Mozilla::DOM.

      Here is error message:

      127:~/.cpan/build/Mozilla-DOM-0.21# perl Makefile.PL Package mozilla-xpcom was not found in the pkg-config search path. Perhaps you should add the directory containing `mozilla-xpcom.pc' to the PKG_CONFIG_PATH environment variable No package 'mozilla-xpcom' found Package firefox-xpcom was not found in the pkg-config search path. Perhaps you should add the directory containing `firefox-xpcom.pc' to the PKG_CONFIG_PATH environment variable No package 'firefox-xpcom' found Package mozilla-firefox-xpcom was not found in the pkg-config search p +ath. Perhaps you should add the directory containing `mozilla-firefox-xpcom +.pc' to the PKG_CONFIG_PATH environment variable No package 'mozilla-firefox-xpcom' found *** can not find package for any of (mozilla-xpcom >= 1.7, firefox-xpc +om >= 1.0, mozilla-firefox-xpcom >= 1.0) *** check that one of them is properly installed and available in PKG_ +CONFIG_PATH at Makefile.PL line 43

      As i realize i need mozilla-xpcom and i install all packages that apt-cache search list to me. But i can't find where mozilla-xpcom.pc is located (i looked at /usr/lib/pkgconfig).

      Can you suggest something?

      I believe the package is libxul-dev. The following patch, applied to Mozilla::DOM's Makefile.PL resolves the dependency and allows a compile and test to work successfully (at least for me on Debian SID).
      --- Makefile.PL 2007-06-06 22:40:06.000000000 +0200 +++ /home/reenen/tmp/Makefile.PL 2008-05-07 14:41:16.204005 +648 +0200 @@ -14,6 +14,7 @@ # someone mentioned adding iceweasel (debian), but I don't # know how it's called +my $icepkg = 'xulrunner-xpcom'; my $mozpkg = 'mozilla-xpcom'; my $ffpkg = 'firefox-xpcom'; my $mffpkg = 'mozilla-firefox-xpcom'; @@ -21,6 +22,7 @@ our %build_reqs = ( 'perl-ExtUtils-Depends' => '0.205', 'perl-ExtUtils-PkgConfig' => '1.07', + $icepkg => '1.7', $mozpkg => '1.7', $ffpkg => '1.0', $mffpkg => '1.0', @@ -40,7 +42,8 @@ exit 1; # not reached } -my %pkgcfg = ExtUtils::PkgConfig->find("$mozpkg >= " . $build_req +s{$mozpkg}, +my %pkgcfg = ExtUtils::PkgConfig->find( "$icepkg >= " . $build_re +qs{$icepkg}, + "$mozpkg >= " . $build_req +s{$mozpkg}, "$ffpkg >= " . $build_reqs +{$ffpkg}, "$mffpkg >= " . $build_req +s{$mffpkg});

Log In?
Username:
Password:

What's my password?
Create A New User
Domain Nodelet?
Node Status?
node history
Node Type: note [id://650473]
help
Chatterbox?
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others musing on the Monastery: (2)
As of 2021-10-24 18:36 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?
    My first memorable Perl project was:







    Results (89 votes). Check out past polls.

    Notices?