http://qs321.pair.com?node_id=605067

jdtoronto has asked for the wisdom of the Perl Monks concerning the following question:

Esteemed monks,

I have been trying to install Data::Ical using CPAN because it is not in the current ActiveState PPM repository. Using PPM I have made sure I have all the dependencies installed, then I run the CPAN install and this is what I get.

CPAN.pm: Going to build J/JE/JESSE/Data-ICal-0.13.tar.gz *** Module::AutoInstall version 1.03 *** Checking for Perl dependencies... [Core Features] - Test::More ...loaded. (0.47) - Test::Warn ...loaded. (0.08) - Test::NoWarnings ...loaded. (0.083) - Test::LongString ...loaded. (0.09) - Class::Accessor ...loaded. (0.22) - Text::vFile::asData ...loaded. (0.05) - MIME::QuotedPrint ...loaded. (3.07) - Class::ReturnValue ...loaded. (0.53) *** Module::AutoInstall configuration finished. Checking if your kit is complete... Looks good Writing Makefile for Data::ICal Microsoft (R) Program Maintenance Utility Version 1.50 Copyright (c) Microsoft Corp 1988-94. All rights reserved. cp lib/Data/ICal/Entry/FreeBusy.pm blib\lib\Data\ICal\Entry\FreeBusy.p +m cp lib/Data/ICal/Entry/TimeZone.pm blib\lib\Data\ICal\Entry\TimeZone.p +m cp lib/Data/ICal/Entry/Alarm/Display.pm blib\lib\Data\ICal\Entry\Alarm +\Display.pm cp lib/Data/ICal/Entry/TimeZone/Standard.pm blib\lib\Data\ICal\Entry\T +imeZone\Standard.pm cp lib/Data/ICal/Entry.pm blib\lib\Data\ICal\Entry.pm cp lib/Data/ICal/Entry/Alarm/Procedure.pm blib\lib\Data\ICal\Entry\Ala +rm\Procedure.pm cp lib/Data/ICal/Entry/TimeZone/Daylight.pm blib\lib\Data\ICal\Entry\T +imeZone\Daylight.pm cp lib/Data/ICal/Entry/Alarm/Email.pm blib\lib\Data\ICal\Entry\Alarm\E +mail.pm cp lib/Data/ICal/Entry/Alarm/Audio.pm blib\lib\Data\ICal\Entry\Alarm\A +udio.pm cp lib/Data/ICal/Entry/Journal.pm blib\lib\Data\ICal\Entry\Journal.pm cp lib/Data/ICal/Property.pm blib\lib\Data\ICal\Property.pm cp lib/Data/ICal/Entry/Event.pm blib\lib\Data\ICal\Entry\Event.pm cp lib/Data/ICal.pm blib\lib\Data\ICal.pm cp lib/Data/ICal/Entry/Todo.pm blib\lib\Data\ICal\Entry\Todo.pm Undefined subroutine &main::UpdateHTML_blib called at -e line 1. NMAKE : fatal error U1077: 'C:\WINDOWS\system32\cmd.exe' : return code + '0xff' Stop. nmake -- NOT OK Running make test Can't test without successful make Running make install make had returned bad status, install seems impossible cpan>
Sadly, I have no clue what is going on here, can anybody offer any advice about how to get this to work? If that is possible of course!

jdtoronto