I've heard little in the gist of "hey that's great, i wish more modules had synonyms!".
At least for me, hearing your thoughts on this puts the dirt in the grave. Thank you.
I'm going to take out the synonyms.
I still have to make up my mind about which to keep. For example- the method named abs_path is more intuitive, at the same time good sense would be to call it get_absolute_path. So I have to pick between the shorties and the longsies. More like the midsies.
Which to pick it's a hard call.. Consistent. Should I make braindead named routines (rel_path vs get_relative_path) because that's what's expected (because other modules have already named things a certain way)? That is a form of consistency.