Beefy Boxes and Bandwidth Generously Provided by pair Networks
P is for Practical
 
PerlMonks  

POE::Component::IRC version 4.70 [Windows ActivePerl]

by mulander (Monk)
on Oct 06, 2005 at 13:18 UTC ( #497915=perlquestion: print w/replies, xml ) Need Help??

mulander has asked for the wisdom of the Perl Monks concerning the following question:

Hellow fellow monks.
I have a problem in optaining POE::Component::IRC, CPAN informs that the newest version of this module is 4.70 but I simply can't find the package of this version for ActivePerl 5.8.7. I searched the standard repositories, and also searched all repositories added via PPM::Repositories unfortunetly with no results ( well being honest the only reusult was POE::Component::IRC version 2.9 witch does not satisfy me ). I must point out that I have no C compiler so so I am not able to compile the package on my own ( another thing that I am not ashamed of confessing to is that I am also afraid that if I somehow manage to install/compile the package on my own, is that I could mess up something ;P )
Now to the point of this node, my question is does anyone know of a repositorie with POE::Component::IRC 4.70 not listed in the PPM::Repositories? And if that person would be so kind to reply with the adress of such a repositorie I would be really gratefull as it is 2 days know that I'm trying to get my hands on it ;)
Thank you for the time you spend reading this and I appologise if someone considers this node as a complete waist of both his and my time.
  • Comment on POE::Component::IRC version 4.70 [Windows ActivePerl]

Replies are listed 'Best First'.
Re: POE::Component::IRC version 4.70 [Windows ActivePerl]
by marto (Cardinal) on Oct 06, 2005 at 13:30 UTC
    Hi,

    A quick check of ppm.activestate.com reports that POE::Component::IRC version 4.70 is not available for the Windows platform.

    "another thing that I am not ashamed of confessing to is that I am also afraid that if I somehow manage to install/compile the package on my own, is that I could mess up something "

    You may want to read the A guide to installing modules for Win32 tutorial.

    Hope this helps

    Martin
Re: POE::Component::IRC version 4.70 [Windows ActivePerl]
by randyk (Parson) on Oct 06, 2005 at 15:12 UTC
    I just put up a POE-Component-IRC ppm package in the uwinnipeg repository, including updated packages of the dependencies not available in ActiveState's repository.
      Thank you very much, this solves my problem.

Log In?
Username:
Password:

What's my password?
Create A New User
Domain Nodelet?
Node Status?
node history
Node Type: perlquestion [id://497915]
Approved by tbone1
help
Chatterbox?
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others avoiding work at the Monastery: (5)
As of 2022-01-26 19:50 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?
    In 2022, my preferred method to securely store passwords is:












    Results (70 votes). Check out past polls.

    Notices?