Beefy Boxes and Bandwidth Generously Provided by pair Networks
Perl Monk, Perl Meditation
 
PerlMonks  

Re^4: Unit test failing but "got" and "expected" are equal

by stevieb (Canon)
on Jan 04, 2019 at 21:08 UTC ( #1228051=note: print w/replies, xml ) Need Help??


in reply to Re^3: Unit test failing but "got" and "expected" are equal
in thread Unit test failing but "got" and "expected" are equal

Don't feel bad, at first, I was thinking the same thing :)

Because I just reloaded all of my Pi devices from scratch, I'm unsure if this is an "issue" with the config of the serial device on-board or not quite yet. All I know is that after I built my PCB hard-soldered test platform with all my ICs and sensors I'm testing, but before the OS upgrade, it worked without hiccup.

No software changes to the serial code on my end (or my underlying C code), so I'm thinking it has to be how the device is configured hardware-wise.

  • Comment on Re^4: Unit test failing but "got" and "expected" are equal

Replies are listed 'Best First'.
Re^5: Unit test failing but "got" and "expected" are equal
by kschwab (Vicar) on Jan 05, 2019 at 05:06 UTC
    It's an ascii NAK (negative acknowledge).
    Maybe set hardware flow control, or slower baud rate? Or perhaps NAK means something special in WiringPI?

Log In?
Username:
Password:

What's my password?
Create A New User
Domain Nodelet?
Node Status?
node history
Node Type: note [id://1228051]
help
Chatterbox?
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others chanting in the Monastery: (6)
As of 2022-05-19 12:24 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?
    Do you prefer to work remotely?



    Results (71 votes). Check out past polls.

    Notices?