http://qs321.pair.com?node_id=1225775


in reply to Re: chr() function
in thread chr() function

Please don't tell people to use $a just so they can avoid having to properly declare a real variable name. $a is a piss-poor variable name in general, completely antithetical to writing clear code, and the only reason that works is because of magic which you didn't bother to explain - magic which would one day bite the new guy in the ass if he took your ill-conceived advice and made a habit of using undeclared $as and $bs on a regular basis.

If you're really fixated on not having to properly declare your variables, it's much saner to turn strict off. And "it's much saner to turn strict off" is not something I say lightly, it's a reflection of just how astonishingly bad the advice "change your variable name to $a so you don't have to declare it" is.