Beefy Boxes and Bandwidth Generously Provided by pair Networks
There's more than one way to do things
 
PerlMonks  

Re^5: PAR pp macOs set -mmacosx-version-min

by beech (Parson)
on Jun 21, 2018 at 02:35 UTC ( #1217089=note: print w/replies, xml ) Need Help??


in reply to Re^4: PAR pp macOs set -mmacosx-version-min
in thread PAR pp macOs set -mmacosx-version-min

still generates a binary with the -mmacosx-version-min=10.13 flag.

Hi,

Did you check with CCFLAGS?

If that fails try adding to  CC= or  LD= definition

Did you check on these files (they're what should get installed)?

otool -l binary blib/script/parl.exe otool -l binary blib/script/parldyn.exe

Replies are listed 'Best First'.
Re^6: PAR pp macOs set -mmacosx-version-min
by IB2017 (Pilgrim) on Jun 22, 2018 at 11:03 UTC

    CCFLAGS is set as this

    CCFLAGS = -fno-common -DPERL_DARWIN -mmacosx-version-min=10.07 -fno-strict-aliasing -pipe -fstack-protector-strong -I/usr/local/include -DPERL_USE_SAFE_PUTENV

    I tried adding

    CC = -mmacosx-version-min=10.07 LD = -mmacosx-version-min=10.07

    I still got my binary with 10.13

    I checkt

    otool -l blib/script/parl otool -l blib/script/parldyn

    They both still have 10.13

    I have noticed that when I run "make" I get the following warnings:

    Makefile:848: warning: overriding commands for target `.c.o' Makefile:338: warning: ignoring old commands for target `.c.o' "/Users/fc/perl5/perlbrew/perls/perl-5.24.4/bin/perl" par_pl2c.pl my_p +ar_pl < ../script/par.pl > my_par_pl.c "/Users/fc/perl5/perlbrew/perls/perl-5.24.4/bin/perl" sha1.c.PL cc -c -fno-common -DPERL_DARWIN -mmacosx-version-min=10.13 -fno-strict +-aliasing -pipe -fstack-protector-strong -I/usr/local/include -DPERL_ +USE_SAFE_PUTENV -I/Users/fc/perl5/perlbrew/perls/perl-5.24.4/lib/5.2 +4.4/darwin-2level/CORE -DLDLIBPTHNAME=\"DYLD_LIBRARY_PATH\" -DPARL_E +XE=\"parl\" -DPAR_PACKER_VERSION=\"1.045\" -O3 main.c cc main.o -mmacosx-version-min=10.13 -fstack-protector-strong -L/usr/ +local/lib -L/Users/fc/perl5/perlbrew/perls/perl-5.24.4/lib/5.24.4/da +rwin-2level/CORE -lperl -lpthread -ldl -lm -lutil -lc -o ./par

    Here must be the problem, as I see again the 10.13 value

Log In?
Username:
Password:

What's my password?
Create A New User
Node Status?
node history
Node Type: note [id://1217089]
help
Chatterbox?
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others romping around the Monastery: (2)
As of 2021-04-15 02:48 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?

    No recent polls found

    Notices?