Beefy Boxes and Bandwidth Generously Provided by pair Networks
laziness, impatience, and hubris
 
PerlMonks  

Re: Test::Simple will install, but not be detected as an appropriate dependency in CPAN

by philipbailey (Deacon)
on Jul 07, 2015 at 20:56 UTC ( #1133628=note: print w/replies, xml ) Need Help??


in reply to Test::Simple will install, but not be detected as an appropriate dependency in CPAN

I'm probably missing something here, but doesn't this:

# The following REQUIRED prerequisites were not satisfied: # # Test::More version '0.98' is not in required range '0.99'

mean that you need to install a suitable version of Test::More (not Test::Simple)?

  • Comment on Re: Test::Simple will install, but not be detected as an appropriate dependency in CPAN
  • Download Code

Replies are listed 'Best First'.
Re^2: Test::Simple will install, but not be detected as an appropriate dependency in CPAN
by dasgar (Priest) on Jul 08, 2015 at 13:49 UTC

    If you're missing something, then you're not the only one.

    In the following:

    # Versions for all modules listed in MYMETA.json (including optional o +nes): # # === Configure Requires === # # Module Want Have # ------------------- ---- ---- # ExtUtils::MakeMaker 6.17 6.66 # # === Build Requires === # # Module Want Have # ------------------- ---- ---- # ExtUtils::MakeMaker any 6.66 # # === Test Requires === # # Module Want Have # --------------------- ---- ------- # ExtUtils::MakeMaker any 6.66 # File::Basename any 2.84 # File::Find any 1.23 # File::Spec any 3.40 # File::Spec::Functions any 3.40 # File::Temp 0.19 0.23 # IO::Dir any 1.10 # JSON::PP any 2.27202 # Test::More 0.99 0.98 # lib any 0.63 # utf8 any 1.10 # vars any 1.03 # # === Test Recommends === # # Module Want Have # ---------- -------- -------- # CPAN::Meta 2.120900 2.120921 # # === Runtime Requires === # # Module Want Have # ------------ ---- ------- # B any 1.42_02 # Carp any 1.29 # Exporter any 5.68 # Fcntl any 1.11 # Scalar::Util any 1.27 # strict any 1.07 # warnings any 1.18 # # # *** WARNING WARNING WARNING WARNING WARNING WARNING WARNING WARNING +*** # # The following REQUIRED prerequisites were not satisfied: # # Test::More version '0.98' is not in required range '0.99' #

    I see absolutely no mention of Test::Simple and two spots indicating that Test::More version 0.99 is required and Perl is finding Test::More version 0.98. Plus there are quite a few test error messages that have the following:

    Test::More version 0.99 required--this is only version 0.98 at

    I'm unable to find a single error message in the posted output that mentions Test::Simple. It looks to me like Test::Simple is not the issue and that the OP needs to update Test::More to version 0.99 or newer (latest release version is 1.001014).

      install Test::More
      Installs Test::Simple, More is a package within Simple apparently

Log In?
Username:
Password:

What's my password?
Create A New User
Domain Nodelet?
Node Status?
node history
Node Type: note [id://1133628]
help
Chatterbox?
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others meditating upon the Monastery: (5)
As of 2022-01-24 11:42 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?
    In 2022, my preferred method to securely store passwords is:












    Results (64 votes). Check out past polls.

    Notices?