http://qs321.pair.com?node_id=11152814


in reply to Re: weird problem with macports perl on apple m1/m2 based system
in thread weird problem with macports perl on apple m1/m2 based system

I didn't run your script because I installed p5-tk with MacPorts and got a display error, I think because I have to install xquartz and I'm not interested in doing that right now on this machine. I did just now run the below though, with a 5.34 perl installed via MacPorts on an M1 mac:

% uname -a Darwin ... 21.6.0 Darwin Kernel Version 21.6.0: Mon Apr 24 21:11:17 PD +T 2023; root:xnu-8020.240.18.701.5~1/RELEASE_ARM64_T6000 arm64 % perl -le 'print 12.99 * 16.25' 211.0875