Beefy Boxes and Bandwidth Generously Provided by pair Networks
Perl Monk, Perl Meditation
 
PerlMonks  

Re: 2021 is the year to drop support for Perl < 5.12?

by roboticus (Chancellor)
on Dec 11, 2020 at 15:41 UTC ( #11125003=note: print w/replies, xml ) Need Help??


in reply to 2021 is the year to drop support for Perl < 5.12?

tobyink:

While I'm not really qualified[1] to have an opinion on the issue, you might consider looking for another "natural" breakpoint: specifically the lowest version that gets installed by default among various Operating Systems. I don't know what version[2] that might be, but looking at your 'hoops' argument, I think it feels similar--when people set up a box, they're going to get some minimum version X, and if they need to install an older version to support some application, they'll have a similar circus act to follow.

I don't know if that would give a different result than your suggestion of 5.12 or not, I'm just offering another thing to think about. Personally, I like 5.12 as a minimum version because I use // quite a bit and state occasionally.

Notes:

  1. I've never been primary production support on large systems, so while I'm somewhat of an old hand at using perl, I typically run the version that comes by default when I install a *NIX distribution or Cygwin on a Windows box.
  2. Again, I don't support production systems, so I just grab a distro that I'd like to use and go with it.

...roboticus

When your only tool is a hammer, all problems look like your thumb.

  • Comment on Re: 2021 is the year to drop support for Perl < 5.12?

Replies are listed 'Best First'.
Re^2: 2021 is the year to drop support for Perl < 5.12?
by tobyink (Canon) on Dec 11, 2020 at 16:16 UTC

    RHEL 7 has Perl 5.16. RHEL 6 has Perl 5.10(.1?). Ubuntu 14.04 has Perl 5.18.2.

    But if someone's running a legacy OS, it's probably to support a legacy app, which can probably make do with an older version of my package.

      I collect what distro (276) ships with what perl release here as part of System::Info.


      Enjoy, Have FUN! H.Merijn

      RHEL6 does indeed have 5.10.1. However, it just went EoL at the end of last month so you could well feel justified in crossing that one off the list.


      🦛

Log In?
Username:
Password:

What's my password?
Create A New User
Node Status?
node history
Node Type: note [id://11125003]
help
Chatterbox?
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others browsing the Monastery: (2)
As of 2021-02-28 20:04 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?

    No recent polls found

    Notices?