Beefy Boxes and Bandwidth Generously Provided by pair Networks
P is for Practical
 
PerlMonks  

Re^8: error catching in mongodb and perl

by praveenchappa (Acolyte)
on Nov 10, 2014 at 12:46 UTC ( #1106689=note: print w/replies, xml ) Need Help??


in reply to Re^7: error catching in mongodb and perl
in thread error catching in mongodb and perl

i could not intall MongoDB using cpan ,for maual istall perl Makefile.pl its saying 'file or directory not found',the error list while installing cpan MongoDb is as Below

Unpacking MongoDB-v0.706.0.0.tar.gz Entering MongoDB-v0.706.0.0 Checking configure dependencies from META.json Checking if you have ExtUtils::MakeMaker 0 ... Yes (7.02) Checking if you have Config::AutoConf 0.22 ... Yes (0.305) Checking if you have Path::Tiny 0.052 ... Yes (0.060) Configuring MongoDB-v0.706.0.0 Running Makefile.PL Checking for stdint.h... yes Checking if your kit is complete... Looks good Generating a dmake-style Makefile Writing Makefile for MongoDB Writing MYMETA.yml and MYMETA.json -> OK Checking dependencies from MYMETA.json ... Checking if you have DateTime 0.78 ... Yes (1.12) Checking if you have DateTime::Tiny 0 ... Yes (1.04) Checking if you have Encode 0 ... Yes (2.44) Checking if you have Data::Dump 0 ... Yes (1.21) Checking if you have File::Path 0 ... Yes (2.08_01) Checking if you have Test::Deep 0.111 ... Yes (0.113) Checking if you have Try::Tiny 0 ... Yes (0.11) Checking if you have File::Copy 0 ... Yes (2.21) Checking if you have IO::File 0 ... Yes (1.15) Checking if you have Data::Dumper 0 ... Yes (2.131) Checking if you have ExtUtils::MakeMaker 6.59 ... Yes (7.02) Checking if you have Test::More 0.96 ... Yes (1.001009) Checking if you have bigint 0 ... Yes (0.29) Checking if you have Throwable 0 ... Yes (0.102080) Checking if you have Class::MOP::Class 0 ... Yes (2.0402) Checking if you have File::Temp 0.17 ... Yes (0.22) Checking if you have Scalar::Util 0 ... Yes (1.41) Checking if you have Tie::IxHash 0 ... Yes (1.22) Checking if you have File::Spec 0 ... Yes (3.47) Checking if you have Data::Types 0 ... Yes (0.09) Checking if you have Test::Fatal 0 ... Yes (0.008) Checking if you have Safe::Isa 0 ... Yes (1.000005) Checking if you have Moose::Util::TypeConstraints 2 ... Yes (2.0402) Checking if you have FileHandle 0 ... Yes (2.02) Checking if you have boolean 0 ... Yes (0.42) Checking if you have Digest::MD5 0 ... Yes (2.51) Checking if you have lib 0 ... Yes (0.63) Checking if you have Moose 2 ... Yes (2.0402) Checking if you have version 0 ... Yes (0.95) Checking if you have Time::HiRes 0 ... Yes (1.9724) Checking if you have threads 0 ... Yes (1.85) Checking if you have Carp 0 ... Yes (1.23) Checking if you have utf8 0 ... Yes (1.09) Checking if you have namespace::clean 0 ... Yes (0.22) Checking if you have Test::Warn 0 ... Yes (0.23) Checking if you have Authen::SCRAM::Client 0.003 ... Yes (0.005) Checking if you have JSON 2 ... Yes (2.90) Checking if you have Devel::Peek 0 ... Yes (1.07) Checking if you have Syntax::Keyword::Junction 0 ... Yes (0.003008) Building and testing MongoDB-v0.706.0.0 cp lib/MongoDB/Connection.pm blib\lib\MongoDB\Connection.pm cp lib/MongoDB/Code.pm blib\lib\MongoDB\Code.pm cp lib/MongoDB/Database.pm blib\lib\MongoDB\Database.pm cp lib/MongoDB.pm blib\lib\MongoDB.pm cp lib/MongoDB/BSON.pm blib\lib\MongoDB\BSON.pm cp lib/MongoDB/DataTypes.pod blib\lib\MongoDB\DataTypes.pod cp lib/MongoDB/MongoClient.pm blib\lib\MongoDB\MongoClient.pm cp lib/MongoDB/CommandResult.pm blib\lib\MongoDB\CommandResult.pm cp lib/MongoDB/OID.pm blib\lib\MongoDB\OID.pm cp lib/MongoDB/GridFS.pm blib\lib\MongoDB\GridFS.pm cp lib/MongoDB/DBRef.pm blib\lib\MongoDB\DBRef.pm cp lib/MongoDB/Role/_LastError.pm blib\lib\MongoDB\Role\_LastError.pm cp lib/MongoDB/Cursor.pm blib\lib\MongoDB\Cursor.pm cp lib/MongoDB/Error.pm blib\lib\MongoDB\Error.pm cp lib/MongoDB/Examples.pod blib\lib\MongoDB\Examples.pod cp lib/MongoDB/GridFS/File.pm blib\lib\MongoDB\GridFS\File.pm cp lib/MongoDB/BSON/Regexp.pm blib\lib\MongoDB\BSON\Regexp.pm cp lib/MongoDB/Collection.pm blib\lib\MongoDB\Collection.pm cp lib/MongoDB/BulkWriteView.pm blib\lib\MongoDB\BulkWriteView.pm cp lib/MongoDB/BulkWrite.pm blib\lib\MongoDB\BulkWrite.pm cp lib/MongoDB/Indexing.pod blib\lib\MongoDB\Indexing.pod cp lib/MongoDB/BSON/Binary.pm blib\lib\MongoDB\BSON\Binary.pm cp lib/MongoDB/Role/_Writeable.pm blib\lib\MongoDB\Role\_Writeable.pm cp lib/MongoDB/Role/_Updater.pm blib\lib\MongoDB\Role\_Updater.pm cp lib/MongoDB/Role/_Remover.pm blib\lib\MongoDB\Role\_Remover.pm cp lib/MongoDB/Role/_WriteQueue.pm blib\lib\MongoDB\Role\_WriteQueue.p +m cp lib/MongoDB/Role/_View.pm blib\lib\MongoDB\Role\_View.pm cp lib/MongoDB/_Types.pm blib\lib\MongoDB\_Types.pm cp lib/MongoDB/Timestamp.pm blib\lib\MongoDB\Timestamp.pm cp lib/MongoDB/WriteResult.pm blib\lib\MongoDB\WriteResult.pm cp lib/MongoDB/Tutorial.pod blib\lib\MongoDB\Tutorial.pod Running Mkbootstrap for MongoDB () "C:\Dwimperl\perl\bin\perl.exe" "-Iinc" -MExtUtils::Command -e chmod - +- 644 "MongoDB.bs" "C:\Dwimperl\perl\bin\perl.exe" "-Iinc" "C:\Dwimperl\perl\lib\ExtUtils +\xsubpp" -typemap "C:\Dwimperl\perl\lib\ExtUtils\typemap" xs\BSON.x +s > xs\BSON.xsc && "C:\Dwimperl\perl\bin\perl.exe" "-Iinc" -MExtUtils +::Command -e mv -- xs\BSON.xsc xs\BSON.c gcc -c -I. -Ibson -Iyajl -s -O2 -DWIN32 -DPERL_TEXTMODE_SCRIPTS +-DUSE_SITECUSTOMIZE -DPERL_IMPLICIT_CONTEXT -DPERL_IMPLICIT_SYS -fno- +strict-aliasing -mms-bitfields -DBSON_COMPILATION -s -O2 -DVERS +ION=\"v0.706.0.0\" -DXS_VERSION=\"v0.706.0.0\" -o xs\BSON.o "-IC +:\Dwimperl\perl\lib\CORE" xs\BSON.c In file included from bson/bson.h:23, from ./perl_mongo.h:22, from xs\BSON.xs:17: bson/bson-compat.h:96: error: expected '=', ',', ';', 'asm' or '__attr +ibute__' before 'INIT_ONCE' dmake.exe: Error code 129, while making 'xs\BSON.o' -> FAIL Installing MongoDB failed. See C:\Users\PC186032\.cpanm\work\1 +415621698.5988\build.log for details. Retry with --force to force ins +tall it.

Replies are listed 'Best First'.
Re^9: error catching in mongodb and perl
by Loops (Curate) on Nov 10, 2014 at 13:10 UTC

    Am guessing your version of Perl is too old? Your DWIM Perl comes with 5.14.

    Just spun up a Windows box here and installed Strawberry Perl : Version 5.20.1.1 32bit and then "cpanm MongoDB" installed fine.

    If you're able to install Strawberry, hopefully that'd solve the problem for you.

Log In?
Username:
Password:

What's my password?
Create A New User
Domain Nodelet?
Node Status?
node history
Node Type: note [id://1106689]
help
Chatterbox?
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others perusing the Monastery: (3)
As of 2022-07-04 15:53 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?

    No recent polls found

    Notices?