http://qs321.pair.com?node_id=1006018

rovf has asked for the wisdom of the Perl Monks concerning the following question:

Does anybody know where I can get a precompiled XML::LibXML for ActiveState Perl 5.16 (Windows, 32 Bit), or do I have to bite the bullet and compile it from CPAN?

This is what I already tried:

Here the error messages from running
use strict; use warnings FATAL => qw(all); use PPM::Repositories; for ( keys %Repositories ) { print `ppm repository add $_ $Repositories{$_}->{location}`; }
:
Unrecognized ppm command 'repository'; try one of area, config, descri +be, files, gui, help, info, install, list, log, profile, query, remove, +repo, search, tree, uninstall, update, upgrade, verify, or version Usage: ppm <cmd> <arg>... Run 'ppm help' to learn more.
-- 
Ronald Fischer <ynnor@mm.st>

Replies are listed 'Best First'.
Re: Finding precompiled XML::LibXML (5.16, ActiveState)
by BrowserUk (Pope) on Nov 28, 2012 at 13:16 UTC
    It seems that the ppm command line syntax has changed, but the Repositories module has not changed accordingly.

    You wrote this code?:

    print `ppm repository add $_ $Repositories{$_}->{location}`;

    From the error message:

    files, gui, help, info, install, list, log, profile, query, remove, +repo,

    repo not repository?


    With the rise and rise of 'Social' network sites: 'Computers are making people easier to use everyday'
    Examine what is said, not who speaks -- Silence betokens consent -- Love the truth but pardon error.
    "Science is about questioning the status quo. Questioning authority".
    In the absence of evidence, opinion is indistinguishable from prejudice.

    RIP Neil Armstrong

      You wrote this code?

      No, I got it from the aforementioned Node ... but I must admit that I overlooked the 'repo' in the error message. Fixing this, worked, in that I am now able to update the module. Thanks a lot.

      -- 
      Ronald Fischer <ynnor@mm.st>

        Note how the version of PPM used in the tutorial is at least 10 years old ;)

Re: Finding precompiled XML::LibXML (5.16, ActiveState)
by marto (Cardinal) on Nov 28, 2012 at 13:29 UTC

    Where did you get this code? I don't see it as part of PPM::Repositories. As you say, the code you are running seems geared towards an older version of PPM. Your options include running PPM and figuring out what the actual command to add a repository is, and using that.

    Regardless I can't find a 5.16 repo with this module for the 32bit Windows platform. The README has instructions for building this yourself on Windows.

Re: Finding precompiled XML::LibXML (5.16, ActiveState)
by tobyink (Canon) on Nov 28, 2012 at 13:22 UTC

    Looks like ActiveState are attempting to build the PPMs on a machine that has no libxml2 available...

    Build logs.

    It would be great to have an Alien package for libxml2 available.

    perl -E'sub Monkey::do{say$_,for@_,do{($monkey=[caller(0)]->[3])=~s{::}{ }and$monkey}}"Monkey say"->Monkey::do'