http://qs321.pair.com?node_id=627285

rvosa has asked for the wisdom of the Perl Monks concerning the following question:

Dear monks,

I'm trying to build Inline::Java on the machine in the message header (OSX 10.4.10 Intel, default perl) with the JNI, PerlNatives and PerlInterpreter options. make seems to go through okay:
Eupoa:~/Desktop/Inline-Java-0.52 rvosa$ make [ ... snipped scroll bar exploding uninformative stuff, sorry about th +at ... ] chmod 755 ../blib/arch/auto/Inline/Java/JNI/JNI.bundle cp JNI.bs ../blib/arch/auto/Inline/Java/JNI/JNI.bs chmod 644 ../blib/arch/auto/Inline/Java/JNI/JNI.bs Manifying ../blib/man3/Inline::Java::Callback.3pm Manifying blib/man3/Inline::Java.3pm
But when I run make test I get:
t/01_init..............IO object version 1.21 does not match bootstrap + parameter 1.23 at /System/Library/Perl/5.8.6/darwin-thread-multi-2le +vel/DynaLoader.pm line 253.
and subsequent tests fail with Inline saying it only knows about extension languages C, Foo and foo. I'm not sure how to fix this, any suggestions?

Thanks!