in reply to Are sub/method synonyms acceptable coding practice?

The only time I've justified this kind of aliasing to myself in the past was when I realized that I had inconsistent method names in my published API and I wanted to make them consistent in a backwards compatible way.

In the instance I'm thinking of, all my action methods were named verb_noun except one. Instead of changing the API I felt it was better to provide a verb_noun alias for the one noun_verb method.

-- Douglas Hunter